微信小游戏使用fairygui.min.js会触发报错

 fairygui版本是最新的允许二进制的那个版本,老版本也报这个错误
 TypeError: Cannot set property height of #<n> which has only a getter↵    
 at e.applyOnSizeChanged (http://127.0.0.1:63259/game/js ... 52:484)↵   
 at e.__targetSizeChanged (http://127.0.0.1:63259/game/js ... 676:38)↵   
 at i.r.$notifyListener (http://127.0.0.1:63259/game/js/egret.min.js:63:37)↵    
 at i.r.dispatchEvent (http://127.0.0.1:63259/game/js/egret.min.js:58:96)↵    
 at i.r.dispatchEventWith (http://127.0.0.1:63259/game/js/egret.min.js:69:74)↵    
 at i.setSize (http://127.0.0.1:63259/game/js ... 61:547)↵    
 at i.n.renderNow (http://127.0.0.1:63259/game/js ... 75:348)↵    
 at i.n.ensureSizeCorrect (http://127.0.0.1:63259/game/js ... 864:54)↵    
 at i.get [as height] (http://127.0.0.1:63259/game/js ... :55:21)↵    
 at n.get [as height] (http://127.0.0.1:63259/game/stage1/main.min.js:32:6272)"
奇怪的是使用fairygui.js里面的内容就不会报这个错 匪夷所思
js... = js/fairygui.min.js

2 个评论

无从得知原因。没有听过其他人反映。
你从堆栈上面能看出大概什么问题吗?

要回复文章请先登录注册